本文是《帝国cms(共312篇)》专题的第 162 篇。阅读本文前,建议先阅读前面的文章:
网站有接近1000个栏目,当修改栏目顺序时,会出现错误提示。原因是php配置问题,php.ini有个表单最大提交变量数,我们需要把它修改大。
我是用的宝塔,那就直接在软件商店里找到你所使用的PHP版本,点击设置 – 配置文件 – 查找max_input_vars这个默认是未启用的,把;max_input_vars前边的;去掉就可以了,1000改为2000,保存,重启PHP,结局。
如果你是lnmp系统,找到php.ini文件,php.ini地址多半是:/usr/local/php/etc/php.ini
然后用VI命令修改:
vi /usr/local/php/etc/php.ini
查看max_input_vars,有可能是启用了设为的1000,有可能是未启用。我设置成:
max_input_vars = 2000
退出、保存php.ini,并重启php-fpm,问题解决!
您已阅读完《帝国cms(共312篇)》专题的第 162 篇。请继续阅读该专题下面的文章:
本站模板没有任何后门,也不会和我们服务器有任何通信,请您放心使用。
本源码一次性买断,没有二次费用,并享受免费更新。
在使用本站模板时,请不要使用我们的产品从事违反中华人民共和国法律、违反公序良俗的活动,否则我们有权拒绝服务,并配合有关单位予以处置。如果您不符合条件,请勿购买。
售后是指通过QQ与客服联系处理问题,售后过期不影响您对主题的使用和更新。免费三个月售后服务。售后服务时间为工作日早9点到晚5点。如果不在线可以QQ留言,我们会尽快给您答复。
售后服务包括程序的使用、BUG的处理、意见建议等。不包括技术服务、网站优化、二次开发、环境配置、服务器运维等。
代码类商品属于数字化商品,具有可复制性,不支持退款,详见《网络交易管理办法》第二章 第16条 第三类。
请仔细阅读我们的用户协议:用户协议




